Undefined subroutine

Started by jlucas, November 10, 2017, 02:00:40 PM

Previous topic - Next topic


Whenever I try and add a zone or group I'm getting a an error page. 

Internal Server Error
The server encountered an internal error or misconfiguration and was unable to complete your request.
Please contact the server administrator at root@localhost to inform them of the time this error occurred, and the actions you performed just before this error.
More information about this error may be available in the server error log.

When I check the apache logs I'm finding.

[Fri Nov 10 13:37:17.076851 2017] [:error] [pid 6582] Undefined subroutine CGI::multi_param\n at /usr/local/nictool/client/htdocs/group_zones.cgi line 599.\n
[Fri Nov 10 13:44:01.141220 2017] [:error] [pid 6569] Undefined subroutine CGI::multi_param\n at /usr/local/nictool/client/htdocs/group.cgi line 117.\n

I've done some grepping around the scripts in the client folder and I'm not seeing it defined anywhere.  I suspect that I'm possibly missing a perl module, or more likely I'm grasping at straws, but when I run perl Makefile.PL in the server and client it's not seeing anything missing.  I've restarted the httpd processing thinking that maybe something didn't get loaded properly but that didn't help.

I was able to add a new nameserver and user without an issue.  Any help would be appreciated.


Is the CGI module installed? If yes, try updating it. If not, try installing it.


It is in installed

Loaded plugins: fastestmirror
base                                                                                                         | 3.6 kB  00:00:00
epel/x86_64/metalink                                                                                         |  17 kB  00:00:00
epel                                                                                                         | 4.7 kB  00:00:00
extras                                                                                                       | 3.4 kB  00:00:00
puppet5                                                                                                      | 2.5 kB  00:00:00
updates                                                                                                      | 3.4 kB  00:00:00
(1/2): epel/x86_64/updateinfo                                                                                | 847 kB  00:00:00
(2/2): epel/x86_64/primary_db                                                                                | 6.1 MB  00:00:01
Loading mirror speeds from cached hostfile
* base: mirrordenver.fdcservers.net
* epel: mirror.solarvps.com
* extras: distro.ibiblio.org
* updates: mirror.web-ster.com
Package perl-CGI-3.63-4.el7.noarch already installed and latest version
Nothing to do

I removed it and that broke apache, which was to be expected.

[Mon Nov 13 09:39:54.789045 2017] [perl:error] [pid 22659] Can't locate CGI.pm in @INC (@INC contains: /usr/local/lib64/perl5 /usr/local/share/perl5 /usr/lib64/perl5/vendor_perl /usr/share/perl5/vendor_perl /usr/lib64/perl5 /usr/share/perl5 . /etc/httpd) at /usr/local/nictool/client/lib/nictoolclient.conf line 21.\nBEGIN failed--compilation aborted at /usr/local/nictool/client/lib/nictoolclient.conf line 21.\nCompilation failed in require at (eval 2) line 1.\n

I reinstalled it and am getting the same error when I try to add a group or zone.


I spun up another VM and tried this in Debian 9 and 8 and it appears to be working without issues in 8 so I'm going to go ahead with that.  Thanks for the help.