Importing with zone2nic fails

Started by rainer_d, March 13, 2015, 09:59:46 AM

Previous topic - Next topic



I'm trying to import zones by axfr'ing them from the original nameserver.

I use NicTool 2.31.

When I run it, I get:

./ -z zonename.domain -a -s our.ns                                                                                                         
Name "NicToolServerAPI::use_https_authentication" used only once: possible typo at ./ line 62.
Logged in as Import-User
Importing zonename.domain:
Cannot encode unnamed element as 'hash'. Will be encoded as 'map' instead
300 - Sanity error: The mailaddr format replaces the @ with a . (dot).
   *** Failed to create zonename.domain: Sanity error : The mailaddr format replaces the @ with a . (dot).

I tried replacing the files with the stuff from this commit:

But it does not help, I still get that error-message.

The SOA-record looks like this:

zonename.domain.   86400   IN   SOA   our.ns. postmaster.our.domain. 2013081501 10800 3600 604800 86400

Any advice?
FreeBSD - The Power To Serve