Web-Interface reports charset as iso 8859-1 - but everything should be utf8(?)

Started by rainer_d, January 07, 2015, 04:39:32 PM

Previous topic - Next topic



I've upgraded to 2.30 and it seems the web-interface is still announcing it wants data in iso8859-1.
(In the "Content-Type" header, I get "text/html; charset=ISO-8859-1").

I tried setting default charset in apache and I grep'ed through the code - but I could not find a way to make it switch to utf8.

This results in broken umlauts in the comments.

Any ideas?
(This is apache 2.2 on FreeBSD with mod_perl2)

Best Regards,
FreeBSD - The Power To Serve


Hmm, I distinctly recall creating some comments with ü in them just to test, and it worked for me. I'm not sure why it's not working for you. You should be able to inspect the HTTP request with your browser in debug mode and get some more info, such as looking at the HTTP headers, which *should* have utf8 specified in them.


Well, I just had time to check.
What I can do is create a record where the comment has umlauts.
What I can't do is create a zone where the comment has umlauts. I can create it, but the umlauts are garbled - ööö becomes ööö.

The webserver sends
text/html; charset=ISO-8859-1
as Content-Type
But the HTML of t he reply-page seems to say utf8.

I really wonder where it sets the content-type.

FreeBSD - The Power To Serve