• Welcome to The Network People Support Forums. Please login or sign up.

-s apacheconf errors and doesn't seem to have worked.

Started by shealey, September 20, 2011, 03:46:52 am

Previous topic - Next topic

shealey

Hello everyone,

Firstly I have to confess that I'm not SHealey I'm MDay, SHealey is my friend tho, and we've been running a Toaster happily for the best part of 10 years. I'm using his account because not only is this forum not accepting new members, but the mailing list mail-toaster@simerson.net rejected my subscription as SPAM.

We just upgraded our hardware from 4 Sun Netra's to an HP Intel box with much virtualisation capacity,  hence I am in the middle of building a new Toaster to move all our mail config onto.

I've had some fun, which I think might be perl version related, but I'm not 100% sure.

The first issue I ran into was that 'toaster_setup.pl -s ezmlm' hung with no output. So I installed ezmlm-idx from ports reran 'toaster_setup.pl -s ezmlm' which exited happily.

I continued with the installation and all seemed to work well, 'toaster_setup.pl -s test' mostly says ok, and the few FAILEDs are in things I expect.

I was a bit suprised at that as the apache server wasn't running and required me to edit /etc/rc.conf and then run '/usr/local/etc/rc.d/apache22 start' before I discovered that when I go to http://elen.gatrell.org I get the standard apache startpage and looking in /usr/local/etc/apache22/httpd.conf it's all pretty vanilla.

There's the required documents in /usr/local/www so I can hand-hack the httpd.conf to serve them all, but I'm somewhat baffled as on my old toaster there's a /usr/local/etc/apache22/Includes/mail-toaster.conf which seems to have been autogenerated and linked in.

I tried running
[root@elen /usr/local/src/Mail-Toaster-5.29]# toaster_setup.pl -s apache       

/usr/local/bin/toaster_setup.pl script execution complete.

[root@elen /usr/local/src/Mail-Toaster-5.29]# toaster_setup.pl -s apachessl
Argument "ssl" isn't numeric in numeric eq (==) at lib/Mail/Toaster/Setup.pm line 89.

/usr/local/bin/toaster_setup.pl script execution complete.

[root@elen /usr/local/src/Mail-Toaster-5.29]# toaster_setup.pl -s apacheconf
Can't locate object method "conf_patch" via package "Mail::Toaster::Apache" at /usr/local/bin/toaster_setup.pl line 62.

which seems a bit odd too.

I also searched through /usr/local/src/Mail-Toaster-5.29 for conf files and couldn't find anything that looked useful.

So does anyone have any advice, I'm gunna play EVE a while and then get back to this tomorrow. I spose I'll configure apache by hand, but I'd rather not have to.

Some version info

FreeBSD 8.2-RELEASE
perl, v5.10.1 (*) built for amd64-freebsd
Mail-Toaster-5.29

I've also just noticed that despite setting install_portmaster to 1 in toaster_watcher.conf portmaster is not installed

:(


matt

Quote from: shealey on September 20, 2011, 03:46:52 am
Hello everyone,

Firstly I have to confess that I'm not SHealey I'm MDay, SHealey is my friend tho, and we've been running a Toaster happily for the best part of 10 years. I'm using his account because not only is this forum not accepting new members, but the mailing list mail-toaster@simerson.net rejected my subscription as SPAM.


Forum is back to accepting new registrations, and your reg has been manually approved. I had disabled the registration, due to spam bots flooding the server with invalid reg requests.

QuoteWe just upgraded our hardware from 4 Sun Netra's to an HP Intel box with much virtualisation capacity,  hence I am in the middle of building a new Toaster to move all our mail config onto.

I've had some fun, which I think might be perl version related, but I'm not 100% sure.


I doubt it. Mostly just due to not having a recent release of Mail::Toaster published. The version on GitHub shows all the recent changes, and there's been quite a few. I'm testing a 5.30 release right now, that addresses most of what you describe here.

QuoteThe first issue I ran into was that 'toaster_setup.pl -s ezmlm' hung with no output. So I installed ezmlm-idx from ports reran 'toaster_setup.pl -s ezmlm' which exited happily.


I fixed this already, it'll show up in the next release.

QuoteI was a bit suprised at that as the apache server wasn't running and required me to edit /etc/rc.conf and then run '/usr/local/etc/rc.d/apache22 start' before I discovered that when I go to http://elen.gatrell.org I get the standard apache startpage and looking in /usr/local/etc/apache22/httpd.conf it's all pretty vanilla.

There's the required documents in /usr/local/www so I can hand-hack the httpd.conf to serve them all, but I'm somewhat baffled as on my old toaster there's a /usr/local/etc/apache22/Includes/mail-toaster.conf which seems to have been autogenerated and linked in.


Again, fixed in the forthcoming release.

QuoteI've also just noticed that despite setting install_portmaster to 1 in toaster_watcher.conf portmaster is not installed


Fixed. (just now).

I'll try to get 5.30 published today. I'm build testing right now.

shealey

Excellent, thanks Matt, good news all round.

I'll have a look at getting 5.30 from the git repository later on today, or maybe tomorrow, and help you with the testing.

M

Foclonsursore