• Welcome to The Network People Support Forums. Please login or sign up.

Packaging Logmonster for Debian 4.0 Etch

Started by smalcolm, October 28, 2008, 03:01:07 pm

Previous topic - Next topic

smalcolm

The environment I'm working in discourages "make install" for anything so I'm trying to create a Debian Package of Logmonster that will install into Debian version 4.0, codenamed "Etch".


  • Has anyone else attempted this?

  • Are Etch's versions of Compress::Zlib [1.42] and Date::Parse (TimeDate) [1.16] new enough?



If I cannot create a Debian package that works with these older versions of required Perl modules, then perhaps I can use CPAN to (automatically) build recent versions of the dependencies (that install into /usr/local/)?

I have succeeded in using "dh-make-perl" command to create "libapache-logmonster-perl_3.05-1_all.deb" but I had to patch Makefile.PL and manually tweak version numbers in the "./debian/control" file generated by "dh-make-perl".

matt

Nobody has attempted to create Debian packages of Logmonster.
It's likely the versions of the dependencies are more than adequate.