• Welcome to The Network People Support Forums. Please login or sign up.

SOAP Transport Error / Port 8082

Started by mike_tcis, December 14, 2004, 08:00:17 AM

Previous topic - Next topic

mike_tcis

I'm just about done with my NicTool install and have followed the install guide to the letter (including applying the appropriate patches, etc).   My config:

FreeBSD 4.10, Apache2 w/mod_perl2 dso, Perl 5.8.5, MySQL 4.1,  all Perl modules installed via ports, both SOAP::Lite and Apache-DBI patches applied, http.conf configured per the docs, MySQL database and tables created with default values, all content in the default locations in /usr/local/www, etc..

Apache2 starts fine, I can browse to http://my.ip.address/ and get the NicTool login page, but when I put in any values, I get:

SOAP: transport error: http://localhost:8082/soap:" target="_blank">http://localhost:8082/soap: 500 Can't connect to localhost:8082 (connect: Connection refused)

This leads me to believe that a SOAP server process is supposed to be listening on port 8082, but I can't see how/what is supposed to be starting that process.

Any advice is appreciated.

--Mike

mike_tcis

Ok, solved my own problem.

The docs say to use port 8010:

http://www.nictool.com/docs/server/install.shtml" target="_blank">http://www.nictool.com/docs/server/install.shtml

Specifically:

<VirtualHost 127.0.0.1:8010>

However, the nictoolclient.conf has:

$NicToolServerAPI::server_port         = "8082";

..by default.  So, either the first document needs to be changed, or the default server_port should be set to 8010..

--Mike

matt

It doesn't matter what port you run on, just as long as what you've got configure in httpd.conf matches what's in nictoolclient.conf.

I've updated the web page to reflect port 8082. For what it's worth, I run mine on port 8010, but I can't tell you why I opted for that port.

Matt