• Welcome to The Network People Support Forums. Please login or sign up.

tcp.smtp not being updated, roaming users not working without vpopmail_mysql

Started by pbrezny, August 06, 2008, 05:25:12 AM

Previous topic - Next topic

pbrezny

What's the trick to get tcp.smtp updated for roaming users if you're not using vpopmail_mysql?

this is on a freebsd 6.3 system upgraded last week.

toaster was installed over an existing qmail and vpopmail installation and initially had:
vpopmail_mysql =1

Since the initial install I decided not to use mysql, set vpopmail_mysql =0
used the ports tree to remove qmail, vpopmail, tcpserver, and followed the toaster install instructions from the top.

tcp.smtp is being read as I can set my ip address to 'RELAYCLIENT=""' and relay, however when I remove that line and run qmail cdb,

pop or imap doesn't get my address in the cdb for relaying as when rbl_enable =1  sorbs blocks me because of my dynamic address.

Also, I'm missing a setting for reverse dns blocks to work.  I know the tcp.smtp file is being read from putting in my ip static above, but:
=:allow,QMAILQUEUE="/var/qmail/bin/simscan"
:allow,RBLSMTPD="Blocked - Reverse DNS queries for your IP fail. Fix your DNS!"

still allows me to relay when rbl_enable=1

I realize these are unrelated.  but man I'm stuck.

let me know what portions of the toaster-watcher.conf file would be helpful to diagnose and i'll provide.

TIA,

pb
Peter Brezny

purplecat.net

pbrezny

Resolved:

Here's what Matt had to say:

To use the relay feature of vpopmail, you must use qpop3d for your
POP3 server.

Not sure however why smtp auth doesn't override rblsmtp.

Also noted that updates are created in ~vpopmail/etc/open-smtp
Peter Brezny

purplecat.net