• Welcome to The Network People Support Forums. Please login or sign up.

tcpserver not able to bind to address

Started by noratx, April 20, 2008, 03:04:28 AM

Previous topic - Next topic

noratx

April 20, 2008, 03:04:28 AM Last Edit: April 20, 2008, 03:30:13 AM by noratx
Hello guys!

I hope someone can help ne now before i go bald.

I got this error:
tcpserver: fatal: unable to bind: address already used

no matter what i do.
I have searched the forums for this and tried anything i found, but without success...

I can't find anything wrong in toaster-watcher.conf
the log directory belongs to qmaill/qnofiles
no other service is listening to port 25

I have taken the startup config from the run file and made my own script from it, just to test...
and if i change the port, it seems to be working as it should...

Is there anyone of you guys who know what i should do? I'm soon out of hair on my head..  =(

Thanks in advance

/Rickard

Edit:
Could this has anything to do with that i am running everything in a jail?
I got a VPS from a friend that i am trying to run the toaster in.
If so, what could i do to fix this?

noratx

Now i have been trying with several possibillities to get this thing work, but none has been successfull.

I even tried to shut down processess, and disabeling them in rc.conf and rebooted.

This is the output i got:

jail# ps -aux
USER   PID %CPU %MEM   VSZ   RSS  TT  STAT STARTED      TIME COMMAND
root 87055  0.0  0.0  3664  1332  ??  SsJ  10:01AM   0:00.03 /usr/sbin/syslogd -s
root 87177  0.0  0.0 19656  3308  ??  SsJ  10:02AM   0:00.01 /usr/sbin/sshd
root 87184  0.0  0.0  3664  1356  ??  SsJ  10:02AM   0:00.00 /usr/sbin/cron -s
root 87205  0.0  0.0 30628  3668  ??  IsJ  10:02AM   0:00.03 sshd: jail [priv] (sshd)
jail 87208  0.0  0.0 30604  3676  ??  SJ   10:02AM   0:00.05 sshd: jail@ttyp1 (sshd)
jail 87209  0.0  0.0  9128  3316  p1  IsJ  10:02AM   0:00.01 -tcsh (tcsh)
root 87210  0.0  0.0 18372  1732  p1  IJ   10:02AM   0:00.01 su
root 87211  0.0  0.0  9356  3340  p1  SJ   10:02AM   0:00.03 _su (csh)
root 87251  0.0  0.0  4744  1184  p1  R+J  10:04AM   0:00.00 ps -aux
jail# nc -v localhost 25
Connection to localhost 25 port [tcp/smtp] succeeded!


What the f**k could be listening on port 25 that is not running?
(sorry for the harch language, but i'm getting desperate here).

If anyone could please help me i would be the happiest guy in the world. =)