• Welcome to The Network People Support Forums. Please login or sign up.

DNS/rDNS do not match - howto make ISP's ip transparent for my server?

Started by James Moore, September 13, 2007, 01:24:30 AM

Previous topic - Next topic

James Moore

We have a toaster installed qmail server with our ISP serving us up on a DSL.

The DSL modem is connected to our server using PPPoe.  Our server has two NIC cards: one as a router and the other serving up our network.

Our problem is that our mail server sends the email from the ip of the 2nd NIC card but when a rDNS is done the DSL modems ip comes up.  They are starting to block emails as possible SPAM when this rDNS doesn't match the DNS.  How can we solve this problem?  How do we make that DSL ip address transparent?

To elaborate on our setup:

DSL modem(209.xx.xx.26) ---->PPPoe----->NIC1(207.xx.xx.200)----->NIC2(207.xx.xx.201) mail.mydomain.com and ns.mydomain.com

DNSlookup reports mail.mydomain.com and ns.mydomain.com are at 207.xx.xx.201
mail when sent reflects 207.xx.xx.201 in the header BUT
rDNS yeilds 209.xx.xx.66

mail is rejected by some because DNS and rDNS do not match.

Another symptom of the problem:

If I go to a place that displays my ip address when surfing the net such as http://www.lawrencegoetz.com/programs/ipinfo/ it says I am at 209.xx.xx.66 instead of the ip that my server is at 207.xx.xx.201

The simple question then is how do I get that DSL/ISP ip address (209.xx.xx.66) to be transparent?  or, in other words, how do I get my DNS and rDNS to match up?


Thanks in advance for any advice offered.

matt

It's hard to say but from the sounds of it, your DSL provider is using NAT on your IPs, which explains why everything on the internet sees you as coming from the DSL modem/routers IP.

If that is the base, your best solution is to set up qmail to route everything through  your ISP mail server with a default smtproute.

D3s7

I had that problem with my DSL provider as well.  It ended up being a misconfiguration on their end in the DSL router / modem as it was sending out as the WAN address instead of LAN.

A call to them may resolve it as well (or a new DSL router)

Antboy

Quote from: matt on October 13, 2007, 04:41:35 PM
It's hard to say but from the sounds of it, your DSL provider is using NAT on your IPs, which explains why everything on the internet sees you as coming from the DSL modem/routers IP.

If that is the base, your best solution is to set up qmail to route everything through  your ISP mail server with a default smtproute.
Hi,

I work with James, and after hammering things out with our ISP it is indeed their set up.  We have a standard DSL setup, and to go to a dedicated setup that would make the 209 address transparent, we'd have to get new equipment, and almost triple our monthly costs (and they're the cheapest in town).

As an alternative, I'm looking at setting up an account with authstmp.com to act as a relay for mail, which should alleviate the problem, but I'm not exactly where I add authsmtp.com as a relay, as it requires a user name and password.

Thanks.