• Welcome to The Network People Support Forums. Please login or sign up.

fixcrio causes TLS connection issues when sending mail to/through toaster

Started by jerm, June 27, 2007, 03:52:31 PM

Previous topic - Next topic

jerm

I sat here baffled by this one and figured it out only by process of elimination.

I installed a new toaster, everything seemed fairly ok, until i tried sending mail to it from another toaster. in the logs of the originating toaster i was getting:

deferral: TLS_connect_failed:_error:0D07209B:asn1_encoding_routines:ASN1_get_object:too_longZConnected_to_61.71.61.81_but_connection_died (etc..)

i basically found nothing on the internet about this. hence my posting it here for the greater good. 

I was getting similarly odd (though very different) errors trying to send mail from thunderbird, something about not being able to find any encryption protocol in common.

Thinking it was a certificate problem, i tried the same cert with courier and it went swimmingly, it was only when i discovered that submit works and smtp didn't that i compared the two run files and started disabling things.

It turns out that having fixcrio enabled was the problem.

fixcrio sounded like a good idea, but it seems that its functionality just destroys TLS.  I didn't see this documented anywhere, so here it is.

comments?