• Welcome to The Network People Support Forums. Please login or sign up.

Fresh Install... Prototype mismatch

Started by adams, February 24, 2005, 03:57:17 AM

Previous topic - Next topic

adams

Prototype mismatch: sub RRDutil::get_requested_graphs vs ($@) at /root/install/RRDutil-2.08/blib/lib/RRDutil.pm line 142.

I have quite a few of these on the make test.

I am using

ucd-snmp-4.2.6_3    An extendable SNMP implementation
bsdpan-Net-SNMP-5.0.1 Net::SNMP - Object oriented interface to SNMP
rrdtool-1.0.49      Round Robin Database Tools

should i be using snmp 5?

matt

I'm going to guess that you aren't using perl 5.8+. Is that so?

Matt

adams

This is perl, v5.6.2 built for i386-freebsd

Do I have to use perl 5.8? Very Happy My toaster is a bit older. When I install 5.8 qmail-scanner does not like 5.8 even with -DENABLE_SUID.

If I cannot upgrade can i get an older version... Very Happy


matt

Qmail-scanner works just fine with perl 5.8, and you need it for newer version of Mail::Toaster and SpamAssassin, both of which you really, really, really, really want.