• Welcome to The Network People Support Forums. Please login or sign up.

tcpserver: fatal: unable to bind: address already used

Started by hertie, February 03, 2004, 02:57:18 AM

Previous topic - Next topic

hertie

Hi guys

I am running a fairly new Toaster and everything seems to work pretty fine. Getting a few hangs every now and then which drives me crazy but then again what can you do....

Surfing through the logs on a boring afternoon, I ran over this file: /var/log/mail/pop3/current which is filled with these entries (and adding a new line every second):

tcpserver: fatal: unable to bind: address already used

Now I am not using the pop3-feature but installed it anyway. I thought maybe some of the users would like to use pop3.

I then did some research and eliminated the first few causes for this problem:

1. sendmail is off:
/etc/rc.conf states sendmail_enable="NONE"
2. No other programms seems to listen to this port:
"netstat -na | grep 25" reveals nothing much
3. telnet localhost 25 gives the following output:

# telnet localhost 25
Trying ::1...
telnet: connect to address ::1: Connection refused
Trying 127.0.0.1...
Connected to localhost.
Escape character is '^]'.
220 adsl-212-101-16-47.solnet.ch ESMTP

Any ideas what could cause this problem?

regards

Hertie

p.s I am running FreeBSD 4.9

matt

The "hang" problem is almost certainly related to logging. Check the permissions of /var/log/mail and make sure it's owned by "qmaill". The pop3 logging error is because you have both courier and qmail's pop3 daemons running. Use one or the other, not both.

Matt

hertie

Ok, checked the ownership on /var/log/mail. Turns out it is owned by root:wheel. but the subdirectories are all owned by qmill:qnofiles (except maildrop.log which is owned by vpopmail). So I changed the owner of /var/log/mail to qmaill:qnofiles like suggested.

About the other thing: here is the respective line of my toaster-watcher.conf:

pop3_daemon                    = qpop3d  #  qpop3d | courier

Guest

hertie

About the other thing: here is the respective line of my toaster-watcher.conf:

pop3_daemon                    = qpop3d  #  qpop3d | courier
Apart from the toaster-watcher.conf, how can I control whether the qmail or the courier pop3 deamon runs? Couldn't find any startup scripts in /usr/local/etc/rc.d

matt

Courier's pop3 will only start if the file /usr/local/etc/rc.d/pop3.sh is present. Otherwise, it won't run.

Qmail's pop3 daemon needs a link in /service (or /var/service) that points to the supervise directory in /var/qmail/superivse in order to run.

Matt

hertie

matt

Courier's pop3 will only start if the file /usr/local/etc/rc.d/pop3.sh is present. Otherwise, it won't run.
pop3.sh doesn't exist.

Qmail's pop3 daemon needs a link in /service (or /var/service) that points to the supervise directory in /var/qmail/superivse in order to run.[/quote]That does exist.

So now I am confused. It looks to me as if couriers pop3 is not running, still I am getting this error. Is there a way of determinig what application is using a certain port?

hertie

Ok let me try another approach. Suppose all your users are using imap and the pop3-protocol is assumed obsolete. Suppose that the pop3-deamon is only giving you crap. Therefore you don't see no need in running said deamon. How to turn it off? toaster-watcher.conf only lets you choose between the pop3-deamons qmail oder courier, but no option "none" is provided.

Or maybe this isn't a good idea after all?