• Welcome to The Network People Support Forums. Please login or sign up.

toaster_setup.pl -s apache hangs...end of script?

Started by pbrezny, June 14, 2009, 03:03:45 AM

Previous topic - Next topic

pbrezny

June 14, 2009, 03:03:45 AM Last Edit: June 14, 2009, 08:20:06 AM by pbrezny
on a new toaster install. (Mail-Toaster-5.14)

toaster_setup.pl -s apache stops running without returning a prompt:
If you don't like the default values being offered to you, or you
get tired of typing them in every time you generate a SSL cert,
edit your openssl.cnf file. On FreeBSD, it lives at /etc/ssl/openssl.cnf

You can also run 'toaster_setup.pl -s ssl' to update your openssl.cnf file.


Is this normal?

Although I had perl 5.8.9 installed, something seemed to be funky with that.  rebuilding that port seems to have resolved the issue (upgraded to 5.8.9_3)

Also finding that:
toaster_setup.pl -s ezmlm

appears to hang as well
Peter Brezny

purplecat.net

matt

I just repaired another toaster that had a 'perl' issue. Odd, I don't see many of those. In that case, it was the gdbm port that was in need of repair. After fixing (reinstall) that, and then rebuilding perl, all was well. I solved it by paying attention to the perl install, and the error messages and warnings.

pbrezny

Thanks Matt, 

We wound up rebuilding perl over here to which seemed to resolve the for most things, thought something still not quite right.

toaster_setup.pl -s qmail admin is kicking out this error:
toaster_setup.pl -s qmailadmin
Use of uninitialized value in pattern match (m//) at /usr/local/lib/perl5/site_perl/5.8.9/Mail/Toaster/Setup.pm line 4787.
Use of uninitialized value in concatenation (.) or string at /usr/local/lib/perl5/site_perl/5.8.9/Mail/Toaster/Setup.pm line 4788.

at the very start of the run.  Didn't notice it the first time around as it scrolled by quickly when qmailadmin started to build from ports, but re-running toaster_setup.pl -s qmailadmin now with qmailadmin installed, the error's right there.

Any ideas on that one?
Peter Brezny

purplecat.net

canadian-net

July 29, 2009, 02:45:39 AM #3 Last Edit: July 30, 2009, 02:28:02 AM by canadian-net
Still hanging at the Apache ssl screen, rebuilt perl 5.8.9_3 Rebuilt gdbm (although was'nt installed) Freebsd 6.4 This is a fresh install of BSD too, only thing unusual, was cvsuping the ports, before begining. The issue can be duplicated. Fortunately they are test boxes. Any ideas? Also I noticed that bin/toaster_setup.pl -s ports did not install portupgrade. Anything else maybe missing?

The work around, is to run the setup in debug, toaster_setup.pl -s apache -d Its hanging on the creation of the SSL key. Just ctrl C and copy and paste the command in the commandline, after it generates the key, run the toaster_setup.pl -s apache again and it will complete.

However: Install of ezmlm-idx hangs, so I installed by port and vpopmail fails to install apparently due to no auth option selected (defaulting to cdb), and valias option being enabled, even tho they appear in the configure!!??.  So the show has stopped at this point.

pbrezny

We eventually retraced all our problems to perl.  the upgrade to 5.8.9 is not simple.  It's been a while but I think eventually we wound up forcing a rebuild of all ports that used perl the old way referenced here:
http://www.tnpi.net/wiki/Upgrade_Perl

as the perl-after-upgrade script didn't seem to finish the job.

I'll be working on finishing up this install today so will post if still seeing problems after this radical perl removal/reinstall.
Peter Brezny

purplecat.net

pbrezny

Still seeing some issues:

toaster_setup.pl -s ucspi

...

Use of uninitialized value in concatenation (.) or string at /usr/local/lib/perl5/site_perl/5.8.9/Mail/Toa                                                                                         ster/Utility.pm line 1670, <STDIN> line 1.
         pwd: /usr/local/src/ucspi-tcp-0.88
         pwd: /usr/local/src/ucspi-tcp-0.88
should be all done!



I'm assuming these errors shouldn't be ignored, although the script reports things should be ok.
Peter Brezny

purplecat.net

pbrezny

August 12, 2009, 02:23:09 PM #6 Last Edit: August 12, 2009, 02:29:48 PM by pbrezny
Finding that if vpopmail was installed or upgraded by the port, when you run:
toaster_setup.pl -s vpopmail

and it asks if if you want to re-install, it doesn't actually remove the pre-installed port.

only after a pkg_delete vpopmail was I able to get vpopmail to install properly with toaster_setup.pl,
Peter Brezny

purplecat.net

pbrezny

August 18, 2009, 09:03:18 AM #7 Last Edit: August 18, 2009, 09:53:34 AM by pbrezny
I'm definitely still seeing issues.  Might be perl related.  In this case the toaster_setup.pl -s apache hung as observed in the first post in this thread.

         ok, using existing archive: vpopmail-5.4.27.tar.gz
Use of uninitialized value in concatenation (.) or string at lib/Mail/Toaster/Setup.pm line 7446, <STDIN> line 1.


This is on a FreeBSD 7.1 system toaster v 5.14  This was a completely fresh install in an esxi virtual machine, perl was a fresh install with 5.8.9_2.

I've rebuilt perl to 5.8.9_3 no errors or warnings in the output of that build.  pkgdb -F seems ok after the upgrade fixing a few stale dependencies with the exception of this:
Stale dependency: bsdpan-Mail-Toaster-5.14 -> perl-5.8.9_2 (lang/perl5.8):
can't convert nil into String

Seems like perhaps vpopmail-5.4.27 has changed some configure time variables as if I remove the valias option in toaster-watcher.conf the next error I get is:
configure: error: --enable-mysql-logging has been superceded.  Please use --enable-sql-logging instead
'
        };
FATAL ERROR at lib/Mail/Toaster/Setup.pm line 7466


I've hunted around in the toaster scripts to try to find a place to change the variable that's inserted to produce that list of config time options, but I'm so not a programmer.

Hopefully Matt will have some time to perform some tweaks on the 5.14 release of the toaster scripts soon.





Peter Brezny

purplecat.net