• Welcome to The Network People Support Forums. Please login or sign up.

Warning Cannot install Mail::Tools, how do I remove/refresh everything cpan

Started by pbrezny, December 19, 2008, 12:12:21 PM

Previous topic - Next topic

pbrezny

In transferring a not too old toaster to antoher system and attempting an upgrade, I think I've broken some perl modules (a little triggler happy with pkg_delete -f perl...)

I've reinstalled perl from the ground up which seems to have helped and am working through  a complete system upgrade, but:

toaster_setup.pl -s toaster gives me:

detected FreeBSD, installing dependencies from ports
Mail::Tools is installed.
Params::Validate is installed.
CPAN: Storable loaded ok
Going to read /home/cpan/.cpan/Metadata
  Database was generated on Fri, 19 Dec 2008 10:26:53 GMT
Warning: Cannot install Mail::Tools, don't know what it is.
Try the command

    i /Mail::Tools/

to find objects with matching identifiers.
Params::Validate is up to date.
        child exited with value 0


Odd that it says it's installed and warns that it doesn't know what it is.

How do I clean up everything cpan has installed to get the system to start from scratch?

Peter Brezny

purplecat.net