• Welcome to The Network People Support Forums. Please login or sign up.

FreeBSD 6.1 & Mail-Toaster 4.10 issues

Started by debaser, July 21, 2006, 07:14:46 AM

Previous topic - Next topic

debaser

I have a clean FreeBSD 6.1-RELEASE-p2 machine that I have installed the Mail-Toaster-4.10 on (this is my first time installing the toaster).  I used the defaults that came with the toaster for everything.  The installation went fine except for the Apache install (./toaster_setup.pl -s apache), which gave the following error:

apache_conf_patch: applying toaster patches to httpd.conf
apache_conf_patch: httpd.conf is at apache2
apache2 doesn't exist!
at lib/Mail/Toaster/Setup.pm line 99

I found the following in the forums:

---
/Mail-Toaster-4.10/lib/Mail/Toaster/Apache.pm on line 1111

$apacheconf = $self->conf_get_dir($conf) unless (-d $apacheconf);

and i changed it to:

$apacheconf = "/usr/local/etc/apache2";

Now this doesnt actually successfully patch the httpd.conf file, however it will output a "httpd.conf.rej" showing you what it was unable to patch.
---

I made this change and ran ./toaster_setup.pl -s apache again and the script completed fine, tho from what I can tell it did properly update the httpd.conf file and a httpd.conf.rej file was not created like stated above.  From what I've read in the mailing list archives, this is an issue with the Apache2 port.

After this, the rest of the install went smoothly.  I didn't install any of the filtering yet since I wanted to make sure everything else was working first.  This is when I noticed that PHP was not working (trying to bring up Squirrelmail asks you if you want to open or save redirect.php instead of executing the php file).  PHP is installed on my server but in looking at the httpd.conf, there is no LoadModule entry for php, nor was I able to find libphp4.so anywhere.  I know php was not compiled as a static module since httpd -l does not list it. 

Also, in looking at /var/log/maillog, it's showing the following errors:

Jul 21 12:01:32 ej authdaemond: Shared object "libauthldap.so" not found, required by "authdaemond"
Jul 21 12:01:32 ej authdaemond: Installing libauthmysql
Jul 21 12:01:32 ej authdaemond: Shared object "libauthmysql.so" not found, required by "authdaemond"
Jul 21 12:01:32 ej authdaemond: Installing libauthpgsql
Jul 21 12:01:32 ej authdaemond: Shared object "libauthpgsql.so" not found, required by "authdaemond"

Any ideas on what is going on?  Like I said, I kept the defaults in the toaster_watcher.conf file.  Any help would be appreciated.  Thanks.

Rodney

matt

The lang/php4 port had changed and no longer installs the mod_php unless it is compiled with the -DWITH_APACHE set. remove php4 and reinstall so the module gets installed.

for your authdaemon problem, edit /usr/local/etc/authdaemon/authdaemon.conf and remove all but the authvchkpw entry.

Matt

debaser

Do I remove php4 by using 'pkg_deinstall -rR php4' or is there another way this should be removed?  Also, after php4 has been removed, to reinstall php4 do I run ./toaster_setup.pl -s apache or do I reinstall php4 and all the other required packages manually from ports with the -DWITH_APACHE option?

Regarding my authdaemon problem, there was no /usr/local/etc/authdaemon/authdaemon.conf file.  There was a /usr/local/etc/authlib/authdaemonrc file and I edited the authmodule line to include only authvchkpw and that fixed my problem with the error messages in /var/log/maillog. 

This was also in the file:

---
##NAME: authmodulelistorig:3
#
# This setting is used by Courier's webadmin module, and should be left
# alone

authmodulelistorig="authuserdb authvchkpw authpam authldap authmysql authpgsql"
---

Should I leave this section alone like it says above or remove everything except for authvchkpw like I did for the authmodule line? 

Thanks for your help.

Rodney

vantage255

In 4.10 I tried this:

---
/Mail-Toaster-4.10/lib/Mail/Toaster/Apache.pm on line 1111

$apacheconf = $self->conf_get_dir($conf) unless (-d $apacheconf);

and i changed it to:

$apacheconf = "/usr/local/etc/apache2";

Now this doesnt actually successfully patch the httpd.conf file, however it will output a "httpd.conf.rej" showing you what it was unable to patch.
---


but now I am just getting:

chewbacca# toaster_setup.pl -s apacheconf
apache_conf_patch: applying toaster patches to httpd.conf
apache_conf_patch: httpd.conf is at /usr/local/etc/apache22/
conf_patch FAILURE: patch not found!


Where is the patch located in the untared toaster install dir?
I will happlily apply it myself as this is the last thing I need to get this box into production.
HI.   This is my .sig

matt

correct, its in the contrib dir of the mail toaster package.

vantage255

HI.   This is my .sig