• Welcome to The Network People Support Forums. Please login or sign up.

ezmlm and chkuser

Started by shealey, November 30, 2011, 07:37:10 AM

Previous topic - Next topic

shealey

Hi it's MDay masquerading as shealey again, I've just completed the migration to a brand new mail-toaster, you might remember the fun I had with 's in passwords.

Everything seems to be working fine except for moderated ezmlm lists. I did some digging as emails to addresses like

foo-accept-1322677216.38389.flldmkkcoodfnbbojddj@illfm.net

are receiving a 'not existing recipient' from CHKUSER despite there being a .qmail-foo-accept-default in /usr/local/vpopmail/domains/illfm.net

Reading /usr/local/src/mail/netqmail-1.05/netqmail-1.05/chkuser_settings.h I note:

/*
* The following #define set the character used for lists extensions
* be careful: this is a  single char '-' definition, not a "string"
*/
#define CHKUSER_EZMLM_DASH '-'

and
/*
* Enables checking for EZMLM lists
* this define substitutes #define CHKUSER_ENABLE_LISTS
*
*/
#define CHKUSER_ENABLE_EZMLM_LISTS

are both commented out which explains why CHKUSER is failing to correctly check the existence of the above .qmail files.

So it seems that the default install of chkuser doesn't enable ezmlm checking.

If I were to edit  /usr/local/src/mail/netqmail-1.05/netqmail-1.05/chkuser_settings.h to enable those options and then was to rerun toaster_setup.pl -s netqmail would that fix this issue or not?

thanks

M

matt

Go ahead and edit those files, but don't reinstall the toaster_setup. It builds everything fresh from sources, and it'll wipe out yours and replace them with new. It's smart (or rude, depending on your perspective) that way.

After editing those files, stop qmail and reinstall by running 'make setup' in the netqmail-1.05 dir. Then test. If it solves your problem, let me know and I'll make toaster_setup do that automatically when building qmail.

shealey

Ok I was partially right and partially wrong as usual.

I obviously haven't done enough C lately as it was only when I opened the .h in vim I realised that the options I mention above are, infact, enabled.

#define is not commented out

However if we look further down in chkuser_setting.h we find


/***************************************************
*
*      new/modified defines in/from 2.0.7
*
**************************************************/

/*
* Uncomment next define to accept recipients for
* aliases that have a -default extension
*/
*/#define CHKUSER_ENABLE_ALIAS_DEFAULT */



Which is commented out.

I can happily report that uncommenting this and running 'make setup' has resolved the issue of chkuser blocking ezmlm list moderation mails.

M