• Welcome to The Network People Support Forums. Please login or sign up.
September 25, 2021, 11:33:23 AM

Fun with 5.30

Started by shealey, October 20, 2011, 05:43:54 AM

Previous topic - Next topic

shealey

Hello MDay again masquerading as shealey

So I'm trying out 5.30
I've installed FreeBSD  REALEASE-amd64-dvd1

During the install it asked me if I wanted to install any packages, so I said yes please I'll have perl-5.10.1_3

So now when I do
elen# perl -v

This is perl, v5.10.1 (*) built for amd64-freebsd


I downloaded and installed Mail::Toaster the make deps ran fine, make test threw some errors but the docs say to expect that and make install ran fine.

Now when I do

elen# bin/toaster_setup.pl -s ports
Can't locate Params/Validate.pm in @INC (@INC contains: lib /usr/local/lib/perl5/5.10.1/BSDPAN /usr/local/lib/perl5/site_perl/5.10.1/mach /usr/local/lib/perl5/site_perl/5.10.1 /usr/local/lib/perl5/5.10.1/mach /usr/local/lib/perl5/5.10.1 .) at lib/Mail/Toaster.pm line 10.
BEGIN failed--compilation aborted at lib/Mail/Toaster.pm line 10.
Compilation failed in require at bin/toaster_setup.pl line 10.
BEGIN failed--compilation aborted at bin/toaster_setup.pl line 10.


So I ran make deps again and noticed that it finishes with

  CPAN.pm: Going to build D/DR/DROLSKY/Params-Validate-1.00.tar.gz

Module::Build version 0.3601 required--this is only version 0.340201 at Build.PL line 5.
BEGIN failed--compilation aborted at Build.PL line 5.
No 'Build' createdWarning (usually harmless): 'YAML' not installed, will not store persistent state
  DROLSKY/Params-Validate-1.00.tar.gz
  /usr/bin/perl Build.PL  -- NOT OK
Running Build test
  Make had some problems, won't test
Running Build install
  Make had some problems, won't install
Could not read '/root/.cpan/build/Params-Validate-1.00-8jXPRH/META.yml'. Falling back to other methods to determine prerequisites
CPAN: Module::Build loaded ok (v0.340201)
checking for URI
checking for version
The following modules failed installation:
Params::Validate


So I reinstalled Module::Build from the CPAN shell which installed v 0.3800

and then make deps finishes with


Building Params-Validate
Files found in blib/arch: installing files in blib/lib into architecture dependent library tree
Can't open file Makefile: No such file or directory at (eval 41) line 2
Installing /usr/local/lib/perl5/site_perl/5.10.1/mach/auto/Params/Validate/Validate.bs
Installing /usr/local/lib/perl5/site_perl/5.10.1/mach/auto/Params/Validate/Validate.so
Installing /usr/local/lib/perl5/site_perl/5.10.1/mach/Attribute/Params/Validate.pm
Installing /usr/local/lib/perl5/site_perl/5.10.1/mach/Params/ValidatePP.pm
Installing /usr/local/lib/perl5/site_perl/5.10.1/mach/Params/Validate.pm
Installing /usr/local/lib/perl5/site_perl/5.10.1/mach/Params/ValidateXS.pm
Installing /usr/local/lib/perl5/5.10.1/man/man3/Params::Validate.3
Installing /usr/local/lib/perl5/5.10.1/man/man3/Attribute::Params::Validate.3
FreeBSD: Registering installation in the package database
  DROLSKY/Params-Validate-1.00.tar.gz
  ./Build install  -- OK


and now


elen# bin/toaster_setup.pl -s ports
Looking up portsnap.FreeBSD.org mirrors... 5 mirrors found.
Fetching public key from portsnap2.FreeBSD.org... done.
Fetching snapshot tag from portsnap2.FreeBSD.org... done.
Fetching snapshot metadata... done.
Fetching snapshot generated at Thu Oct 20 01:07:38 BST 2011:
d66b6443e34126bd73ce8b0897e40ad6083d937bdd25a2 15% of   64 MB  833 kBps 01m12s


It seems to work.

I don't know if this is your problem, or some upstream module provider, but maybe the make deps should make the latest version of Module::Build as well.

hth

hand

M

shealey

October 21, 2011, 11:51:40 PM #1 Last Edit: October 22, 2011, 12:44:59 AM by shealey
Word to the wise:

Don't enable Gnu PTH in your python2.7 config


===>    Verifying install for /usr/local/bin/python2.7 in /usr/ports/lang/python27
===>  python27-2.7.2_2 is marked as broken: does not build with PTH enabled.



hth

M