• Welcome to The Network People Support Forums. Please login or sign up.

Couldn't 'use NicTool'. Can't locate NicTool.pm please help a newbie

Started by TheNetGuy, December 23, 2004, 12:41:54 AM

Previous topic - Next topic

TheNetGuy

Please help a newbie.
Freebsd 5.3 fresh install
Perl 5.8 install from ports
apache 2 install from ports
applied both DBI and SOAP patches.
Tried to Follow instructions from website.
Been up for hours trying to get this thing up to play with.



When running
cd /usr/local/www/NicToolServer
perl Makefile.PL
Writing Makefile for NicToolServer

make test


PERL_DL_NONLAZY=1 /usr/bin/perl "-Iblib/lib" "-Iblib/arch" test.pl
t/basic..........Couldn't 'use NicTool'. Can't locate NicTool.pm in @INC (@INC contains: ../client /usr/local/lib/perl5/site_perl/5.8.5/mach /usr/local/lib/perl5/site_perl/5.8.5 /usr/local/lib/perl5/site_perl /usr/local/lib/perl5/5.8.5/BSDPAN /usr/local/lib/perl5/5.8.5/mach /usr/local/lib/perl5/5.8.5 .) at (eval 5) line 2.
BEGIN failed--compilation aborted at (eval 5) line 2.

Please either install the NicTool client library, or edit 'test.cfg' to specify its location. at TestConfig.pm line 56.
BEGIN failed--compilation aborted at t/basic.pl line 23.




Please help me fix this.
I reinstalled the nictools client and the server to no avail.
I even searched for Nictool.pm on the system  ( find / | grep NicTool.pm)     but could not find it anywhere.


ALSO
2. What is the default username and password to get into the system? Where is this located in documentation./install instructions?  



etherealnet

Ignore it, the test appears to be broken. I got the same error on make test but nictool server runs fine.