Author Topic: Something is missing, no "gz"  (Read 12164 times)

David Pierron

  • Member
  • ***
  • Posts: 18
  • Karma: +0/-0
    • http://www.icuhost.net
Something is missing, no "gz"
« on: February 10, 2009, 12:01:57 pm »
Feb 1, 2009 marks my 5th anniversary on these forums ... thanks Matt!  You have helped me in so many ways.

[EDIT: 02/13/2009 = RESOLVED]
I think I was running Logmonster a day early in that there wasn't a log file to process or something, or there was something going on from the command line an dI am using webalizer as the processor and that is touchy as well.  I deleted all stats dirs and processing from when it was installed and utilized the "-b N" for those days and stats accumulated and worked as expected.  I don't know what the gz "gzip" issue was but when I install on another server I will pay close attention.  Thanks to those that considered answering me here, but I think I just did something that somebody didn't like out of sequence.  Who knows?  But Logmonster is great for web stats on a shared hosting machine.
[/EDIT]

I am running a fairly vanilla FreeBSD 7.0-RELEASE-p5 ... I downloaded Logmonster from the store and followed the instructions within the file README and in the Wiki ... I made sure the PreReq's were installed and cronolog, webalizer ... my apache conf edited, etc.

Logmonster won't run because there isn't a *.gz file in the log directory.  If I rename access.log to access.log.gz Logmonster will run successfully.

[my_system]# pkg_info | grep zip
p5-IO-Compress-Zlib-2.015 Perl5 interface for reading and writing of (g)zip files
unzip-5.52_5        List, test and extract compressed files in a ZIP archive

Am I missing an archiver or a cron job?

and FYI, the following was not changed in this source downloaded 02/03/2009:

$ svn diff lib/Apache/Logmonster.pm
Index: lib/Apache/Logmonster.pm
===================================================================
--- lib/Apache/Logmonster.pm    (revision 539)
+++ lib/Apache/Logmonster.pm    (working copy)
@@ -422,7 +422,7 @@
     my $debug       = $self->{'debug'};
     my $conf        = $self->{'conf'};
     my $REPORT      = $self->{'report'};
-    my $interval    = $self->{'rotational_interval'};
+    my $interval    = $self->{'rotation_interval'};
 
        my ($cmd, $r);
« Last Edit: February 13, 2009, 12:54:17 am by David Pierron »

matt

  • Administrator
  • Wizard
  • *****
  • Posts: 635
  • Karma: +0/-0
    • Matt's Personal Site
Re: Something is missing, no "gz"
« Reply #1 on: February 18, 2009, 10:32:55 pm »
If you read through the docs for Logmonster, you'll note it mentions cronolog. Do you have your logs set up as described? If so, they should be getting gzipped for you, automatically.

David Pierron

  • Member
  • ***
  • Posts: 18
  • Karma: +0/-0
    • http://www.icuhost.net
Re: Something is missing, no "gz"
« Reply #2 on: February 19, 2009, 01:31:44 pm »
Yeah, I think my problem was that I wanted to get it working right away.  Some patience should be assumed in there between enabling the apache logs and actually beginning to utilize Logmonster.