• Welcome to The Network People Support Forums. Please login or sign up.
September 25, 2021, 12:08:52 PM

Errors while patching

Started by kshitijtambe, April 04, 2006, 04:33:30 AM

Previous topic - Next topic

kshitijtambe

I am using mod_perl with Apache2 on a RHEL 3 machine and have installed the latest version of NicTool. I am trying to apply the patch for SOAP::Lite and the DBI patch ( HTTP.pm.patch & DBI.pm.patch ) however the application of patch keeps failing for either case. Can someone help.

Here is what I am doing

# cd /usr/lib/perl5/site_perl/5.8.0/SOAP/Transport/
# cp -p HTTP.pm HTTP.pm.orig
# wget http://nictool.com/docs/server/HTTP.pm.patch" target="_blank">http://nictool.com/docs/server/HTTP.pm.patch

(Received the patch)

# patch -p1 < HTTP.pm.patch
missing header for unified diff at line 3 of patch
can't find file to patch at input line 3
Perhaps you used the wrong -p or --strip option?
The text leading up to this was:
--------------------------
|--- HTTP.pm.dist       Sat Dec 11 14:27:34 2004
|+++ HTTP.pm    Sat Dec 11 14:28:05 2004
--------------------------
File to patch:

# patch -p1 < HTTP.pm.patch
missing header for unified diff at line 3 of patch
can't find file to patch at input line 3
Perhaps you used the wrong -p or --strip option?
The text leading up to this was:
--------------------------
|--- HTTP.pm.dist       Sat Dec 11 14:27:34 2004
|+++ HTTP.pm    Sat Dec 11 14:28:05 2004
--------------------------
File to patch: HTTP.pm
patching file HTTP.pm
Hunk #1 FAILED at 11.
Hunk #2 FAILED at 458.
Hunk #3 FAILED at 474.
Hunk #4 FAILED at 497.
Hunk #5 FAILED at 620.
Hunk #6 FAILED at 837.
Hunk #7 FAILED at 860.
7 out of 7 hunks FAILED -- saving rejects to file HTTP.pm.rej

Same happens for DBI.pm

Thanks
KT


monachus

I was not able to get the current versions of NicTool to work with mod_perl2, apache2, and the latest perl mods for SOAP::Lite, etc.  

The patches provided are from more than 18 months ago.  One of the issues with SOAP::Lite has already been fixed, but it appears that changes in mod_perl2 render NicTool unusable in its current state.  I had to roll back to Apache1 for my installation.

Matt - if you need an Apache2 installation to sandbox/dev in, let me know.
Adrian Goins - President / CEO
Arces Network, LLC
http://www.arces.net

PGP Key: 1024D/8AADA4B8 2009-04-20
Fingerprint: E3CD 96EA DF3F B345 7ADB  FB74 31EC 9F54 8AAD A4B8

matt

The patch is no longer necessary for use with Apache2. I updated the install page (http://www.nictool.com/docs/server/install.shtml" target="_blank">http://www.nictool.com/docs/server/install.shtml) and included a link to the discussion thread that has more information.

neojedi

The thread links don't seem to take me to the thread. Can you check this?