• Welcome to The Network People Support Forums. Please login or sign up.

Login bounces back to login page

Started by MarkS, September 11, 2005, 06:29:54 AM

Previous topic - Next topic

MarkS

I suddenly appear unable to login into Nictool. So far as I'm aware nothing has changed other than an updated install of exim, clamAV and libspf which shouldn't affect anything relevant to Nictool.
I turned the SOAP debug options on in nictoolclient.conf and am seeing the following in Apache's error.log:

Quote:

Calling soap function "login" with params:
$VAR1 = {
         'nt_protocol_version' => '1.0',
         'password' => '<snip>',
         'username' => '<snip>'
       };

SOAP result SCALAR: $VAR1 = '
junk after document element at line 2, column 281, byte 303 at  /usr/lib/perl5/vendor_perl/5.8.6/i686-linux-thread-multi/XML /Parser.pm line 187
<?xml version="1.0"?>
<methodResponse><params><param><value><struct><member><name >error_msg</name><value><string>Your session has expired. Please login again</string></value></member><member><name>error_code </name><value><int>403</int></value></member></struct ></value></param></params></methodResponse><!DOCTYPE HTML PUBLIC "-//IETF//DTD HTML 2.0//EN">
<html><head>
<title>200 OK</title>
</head><body>
<h1>OK</h1>
<p>The server encountered an internal error or
misconfiguration and was unable to complete
your request.</p>
<p>Please contact the server administrator, and inform them of the time the error occurred,
and anything you might have done that may have
caused the error.</p>
<p>More information about this error may be available
in the server error log.</p>


<address>Apache/2.0.52 (Gentoo/Linux) mod_perl/1.99_11 Perl/v5.8.6 mod_ssl/2.0.52 OpenSSL/0.9.7g PHP/4.4.0 Server at localhost Port 8082</address>
</body></html>
';



I presumed the problem had something to do with XML::Parser so I completely uninstalled and reinstalled it in case there was a corruption in parser.pm.  This had no effect whatsoever.

Environment is as follows:
Gentoo Linux
Apache 2.0.52
Nictool 2.03
Perl 5.8.6
mod_perl 1.99

If I login in with a username but no password it gives "Please enter you username and password!", but if I login with any arbitary username / password (incl. the correct ones and ones such as blah/blah)), it simply returns to the login page.

Any ideas what might have gone wrong and how I can start fixing it?



LogicX

I assume you've tried restarting apache -- but I'd just like to confirm this.
--- May this post be indexed by spiders, and archived for all to see as my internet epitaph.
http://FPuX.com" target="_blank">http://FPuX.com

MarkS

Yep, I restart apache after any changes. I also haven't noticed any other related errors in any of the other logfiles.

MarkS

Any ideas anyone?  I'm having to make my changes directly in the mysql database and I have no idea if that's going to cause other issues at all?

MarkS

I've noticed that a lot of others seem to be experiencing similar errors to mine, but they all appear to be running mod_perl2 and also have not posted any resolutions. I've doublechecked my mod_perl and it's definitely 1.99.

matt

The last server I installed NicTool on was using: mod_perl2-2.0.0r3, and that works just fine with a few tweaks (as documented on the NicTool web site).

I haven't tried it with mod_perl 2.0.0 or later. Fortunately, the FreeBSD port refuses to upgrade successfully due to port conflicts. I'm not liable to try it again with newer version of mod_perl until I need to install NicTool on a new server.

If you aren't comfortably hacking around with mod_perl, then you may want to consider staying with Apache 1.x until mod_perl 2 has stabilized. It's stabilizing but still in a state of flux.